#V3 Testnet Feedback# takeshi7's Problems with Ledger


Here are my thoughts after using the ZKSwap testnet to perform a swap, mint an NFT, and try to qualify for the upcoming airdrop. Right off the bat, it was impossible to use the Ledger wallet that is synced to my Meta Mask account. I’m using Google Chrome on Windows 10, and every time I would try to link the wallet with ZKSwap the “unlock address” button would do nothing, and just go back to the same screen with the “unlock address” button.

So I had to switch to the normal Meta Mask wallet instead of being able to use my Ledger. Not a deal breaker, but I would have preferred to use Ledger. The next issue I ran into was not the fault of ZKSwap V3, but rather that every Rinkeby test faucet to get ETH was not working. I tried every single one. Eventually I got frustrated and gave up for a few days. I have no clue why it didn’t occur to me at the time, but eventually I realized I could use the ZKSwap to simply swap my testnet USDT and ZKS tokens to get the required ETH. It was quick and painless, although the first transaction failed because the default slippage (0.5%) was too low. Since this was a testnet I just changed it to 5% and the transaction went through just fine.

From there I was able to easily and quickly mint an NFT. This is the first NFT I’ve ever minted, and the process was extremely easy and smoot. Good job on that aspect. Your team nailed it. I really think ZKSwap has a bright future based on my experience. Sure, there was a single kink that need to be worked out in the form of Ledger Meta Mask wallet support, but I have faith that can be achieved. The rest of it really blew me away how easy it was. I am not a Defi or L2 expert by any means, but this gives me hope for the future of the space.

Thanks for reading.